CVE-2025-48734 Apache Commons BeanUtils: PropertyUtilsBean does not suppresses an enum's declaredClass property by default

High 8.8 Published Updated

Attackers can access enum class loaders via declaredClass property to execute arbitrary code if external input controls property paths.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48734?

CVE-2025-48734 is a high-severity vulnerability in Apache Commons BeanUtils 1.x, published on 28 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Access Control vulnerability in Apache Commons.

A special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default. PropertyUtilsBean (and consequently BeanUtilsBean) now disallows declared class level property access by default.

Releases 1.11.0 and 2.0.0-M2 address a potential security issue when accessing enum properties in an uncontrolled way. If an application using Commons BeanUtils passes property paths from an external source directly to the getProperty() method of PropertyUtilsBean, an attacker can access the enum’s class loader via the “declaredClass” property available on all Java “enum” objects. Accessing the enum’s “declaredClass” allows remote attackers to access the ClassLoader and execute arbitrary code. The same issue exists with PropertyUtilsBean.getNestedProperty(). Starting in versions 1.11.0 and 2.0.0-M2 a special BeanIntrospector suppresses the “declaredClass” property. Note that this new BeanIntrospector is enabled by default, but you can disable it to regain the old behavior; see section 2.5 of the user's guide and the unit tests.

This issue affects Apache Commons BeanUtils 1.x before 1.11.0, and 2.x before 2.0.0-M2.Users of the artifact commons-beanutils:commons-beanutils

1.x are recommended to upgrade to version 1.11.0, which fixes the issue.

Users of the artifact org.apache.commons:commons-beanutils2

2.x are recommended to upgrade to version 2.0.0-M2, which fixes the issue.

Weakness: CWE-284

Which versions are affected by CVE-2025-48734?

4 open source packages ship an affected version, including org.apache.commons:commons-beanutils2 and commons-beanutils:commons-beanutils. It affects 1 product.

PackageAffectedFixed in
org.apache.commons:commons-beanutils2 MavenFrom 2.0.0-M12.0.0-M2
org.apache.commons:commons-beanutils2 MavenFrom 2.0.0-M12.0.0-M2
commons-beanutils:commons-beanutils MavenFrom 1.01.11.0
commons-beanutils:commons-beanutils MavenFrom 1.01.11.0
Linux distribution packages (36)
apache-commons-beanutils AlmaLinux:10All versions1.9.4-21.el10_0
apache-commons-beanutils-javadoc AlmaLinux:10All versions1.9.4-21.el10_0
apache-commons-beanutils AlmaLinux:9All versions1.9.4-10.el9_6
apache-commons-beanutils Red Hat:enterprise_linux:10.0All versions0:1.9.4-21.el10_0
apache-commons-beanutils-javadoc Red Hat:enterprise_linux:10.0All versions0:1.9.4-21.el10_0
apache-commons-beanutils Red Hat:enterprise_linux:9::crbAll versions0:1.9.4-10.el9_6
eap7-apache-commons-beanutils Red Hat:jboss_enterprise_application_platform:7.4::el7All versions0:1.11.0-1.redhat_00001.1.el7eap
eap7-apache-commons-beanutils Red Hat:jboss_enterprise_application_platform:7.4::el8All versions0:1.11.0-1.redhat_00001.1.el8eap
eap7-apache-commons-beanutils Red Hat:jboss_enterprise_application_platform:7.4::el9All versions0:1.11.0-1.redhat_00001.1.el9eap
jenkins Red Hat:ocp_tools:4.12::el8All versions0:2.516.2.1756902453-3.el8
jenkins-2-plugins Red Hat:ocp_tools:4.12::el8All versions0:4.12.1756902839-1.el8
jenkins Red Hat:ocp_tools:4.13::el8All versions0:2.516.2.1756902120-3.el8
jenkins-2-plugins Red Hat:ocp_tools:4.13::el8All versions0:4.13.1756901992-1.el8
jenkins Red Hat:ocp_tools:4.14::el8All versions0:2.516.2.1757087588-3.el8
jenkins-2-plugins Red Hat:ocp_tools:4.14::el8All versions0:4.14.1757087858-1.el8
jenkins Red Hat:ocp_tools:4.15::el8All versions0:2.516.2.1756738247-3.el8
jenkins-2-plugins Red Hat:ocp_tools:4.15::el8All versions0:4.15.1756735456-1.el8
jenkins Red Hat:ocp_tools:4.16::el9All versions0:2.516.2.1756733848-3.el9
jenkins-2-plugins Red Hat:ocp_tools:4.16::el9All versions0:4.16.1756734507-1.el9
jenkins Red Hat:ocp_tools:4.17::el9All versions0:2.516.2.1756732303-3.el9
jenkins-2-plugins Red Hat:ocp_tools:4.17::el9All versions0:4.17.1756732064-1.el9
jenkins Red Hat:ocp_tools:4.18::el9All versions0:2.516.2.1756731431-3.el9
jenkins-2-plugins Red Hat:ocp_tools:4.18::el9All versions0:4.18.1756731677-1.el9
jenkins Red Hat:ocp_tools:4.19::el9All versions0:2.516.2.1756903379-3.el9
jenkins-2-plugins Red Hat:ocp_tools:4.19::el9All versions0:4.19.1756901647-1.el9
apache-commons-beanutils Red Hat:rhel_els:7All versions0:1.8.3-15.el7_9.1
apache-commons-beanutils-javadoc Red Hat:rhel_els:7All versions0:1.8.3-15.el7_9.1
apache-commons-beanutils Red Hat:rhel_eus:9.4::crbAll versions0:1.9.4-9.el9_4.1
apache-commons-beanutils Rocky Linux:10All versions0:1.9.4-21.el10_0
apache-commons-beanutils Rocky Linux:9All versions0:1.9.4-10.el9_6
apache-commons-beanutils SUSE:Enterprise Storage 7.1All versions1.11.0-150200.3.9.1
apache-commons-beanutils SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSSAll versions1.11.0-150200.3.9.1
apache-commons-beanutils SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSAll versions1.11.0-150200.3.9.1
apache-commons-beanutils SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSAll versions1.11.0-150200.3.9.1
apache-commons-beanutils SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOSAll versions1.11.0-150200.3.9.1
apache-commons-beanutils SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSSAll versions1.11.0-150200.3.9.1

Products include Apache Commons Beanutils.

How do I fix CVE-2025-48734?

Upgrade org.apache.commons:commons-beanutils2 to 2.0.0-M2 or later.

Is CVE-2025-48734 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48734 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as ALSA-2025:9114, ALSA-2025:9166, AZL-109472, CLEANSTART-2026-CD91859, CLEANSTART-2026-FV16777, CLSA-2025-1754006614 and 52 more.

Is CVE-2025-48734 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free