# CVE-2025-48866: ModSecurity has possible DoS vulnerability in sanitiseArg action

> Attackers can cause denial of service in ModSecurity by exploiting the sanitiseArg action to add excessive arguments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** AZL-62229, AZL-62231, BIT-modsecurity-2025-48866, BIT-modsecurity2-2025-48866, DEBIAN-CVE-2025-48866, DLA-4212-1, OESA-2025-1676, RHSA-2025:12838, RHSA-2025:13670, RHSA-2025:13716, RHSA-2025:13775, RLSA-2025:12838, UBUNTU-CVE-2025-48866

## What is CVE-2025-48866?

CVE-2025-48866 is a high-severity denial of service vulnerability in owasp-modsecurity ModSecurity, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the  `sanitiseArg` (or `sanitizeArg`) action.

Weakness: CWE-1050 (Excessive Platform Resource Consumption within a Loop)

## Which versions are affected by CVE-2025-48866?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | All versions | 3.0.12 |
| `modsecurity2` | Bitnami | All versions | 2.9.10 |
| `mod_security` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.9.6-2.el9_6.1 |
| `mod_security-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.9.6-2.el9_6.1 |
| `mod_security-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.9.6-2.el9_6.1 |
| `mod_security-mlogc` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.9.6-2.el9_6.1 |
| `mod_security-mlogc-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.9.6-2.el9_6.1 |
| `mod_security` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.9.3-12.el9_0.2 |
| `mod_security-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.9.3-12.el9_0.2 |
| `mod_security-debugsource` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.9.3-12.el9_0.2 |
| `mod_security-mlogc` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.9.3-12.el9_0.2 |
| `mod_security-mlogc-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.9.3-12.el9_0.2 |
| `mod_security` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:2.9.6-1.el9_2.2 |
| `mod_security-debuginfo` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:2.9.6-1.el9_2.2 |
| `mod_security-debugsource` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:2.9.6-1.el9_2.2 |
| `mod_security-mlogc` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:2.9.6-1.el9_2.2 |
| `mod_security-mlogc-debuginfo` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:2.9.6-1.el9_2.2 |
| `mod_security` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.9.6-1.el9_4.2 |
| `mod_security-debuginfo` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.9.6-1.el9_4.2 |
| `mod_security-debugsource` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.9.6-1.el9_4.2 |
| `mod_security-mlogc` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.9.6-1.el9_4.2 |
| `mod_security-mlogc-debuginfo` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.9.6-1.el9_4.2 |
| `mod_security` | Rocky Linux:9 | All versions | 0:2.9.6-2.el9_6.1 |

Products: Owasp Modsecurity.

## How do I fix CVE-2025-48866?

Upgrade modsecurity to 3.0.12 or later.

## Is CVE-2025-48866 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48866 exists.

## Other vulnerabilities in owasp-modsecurity ModSecurity

- [CVE-2026-52747](https://insights.sbomify.com/CVE-2026-52747/): Security feature bypass in ModSecurity (high 8.6)
- [CVE-2024-1019](https://insights.sbomify.com/CVE-2024-1019/): WAF bypass of the ModSecurity v3 release line (high 8.6)
- [CVE-2026-42268](https://insights.sbomify.com/CVE-2026-42268/): ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators (high 8.2)
- [CVE-2026-30923](https://insights.sbomify.com/CVE-2026-30923/): libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings (high 8.2)
- [CVE-2023-38285](https://insights.sbomify.com/CVE-2023-38285/): Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48866 and fix it if it is affected.

What it is: CVE-2025-48866 is a high-severity denial of service vulnerability in owasp-modsecurity ModSecurity, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48866 exists.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected all versions; fixed in 3.0.12
- modsecurity2 (Bitnami): affected all versions; fixed in 2.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48866/ (Markdown: https://insights.sbomify.com/CVE-2025-48866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48866
- OSV: https://osv.dev/vulnerability/CVE-2025-48866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48866/
Summaries are generated and may contain mistakes; the official description above is the record.
