# CVE-2025-48877: Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe

> Attackers can execute arbitrary JavaScript in the context of embedded CodePen iframes, potentially leading to session hijacking or data theft.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** BIT-discourse-2025-48877, GHSA-cm93-6m2m-cjcv

## What is CVE-2025-48877?

CVE-2025-48877 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.

Weakness: CWE-1038 (Insecure Automated Optimizations)

## Which versions are affected by CVE-2025-48877?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.4.4 |

Products: Discourse Discourse.

## How do I fix CVE-2025-48877?

Upgrade discourse to 3.4.4 or later.

## Is CVE-2025-48877 being exploited?

There is no known exploitation of CVE-2025-48877 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48877 and fix it if it is affected.

What it is: CVE-2025-48877 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48877 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48877/ (Markdown: https://insights.sbomify.com/CVE-2025-48877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48877
- OSV: https://osv.dev/vulnerability/CVE-2025-48877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48877/
Summaries are generated and may contain mistakes; the official description above is the record.
