# CVE-2025-48879: OctoPrint Vulnerable to Denial of Service through malformed HTTP request

> Unauthenticated attackers can crash the OctoPrint web server by sending malformed multipart requests, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-9wj4-8h85-pgrw, PYSEC-2026-1713

## What is CVE-2025-48879?

CVE-2025-48879 is a medium-severity denial of service vulnerability in OctoPrint, published on 10 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint versions up until and including 1.11.1 contain a vulnerability that allows any unauthenticated attacker to send a manipulated broken multipart/form-data request to OctoPrint and through that make the web server component become unresponsive. The issue can be triggered by a broken multipart/form-data request lacking an end boundary to any of OctoPrint's endpoints implemented through the octoprint.server.util.tornado.UploadStorageFallbackHandler request handler. The request handler will get stuck in an endless busy loop, looking for a part of the request that will never come. As Tornado is single-threaded, that will effectively block the whole web server. The vulnerability has been patched in version 1.11.2.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-140 (Improper Neutralization of Delimiters)

## Which versions are affected by CVE-2025-48879?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.11.2 |
| `octoprint` | PyPI | All versions | 1.11.2 |
| `OctoPrint` | PyPI | All versions | 1.11.2 |

Products: Octoprint Octoprint.

## How do I fix CVE-2025-48879?

Upgrade octoprint to 1.11.2 or later.

## Is CVE-2025-48879 being exploited?

There is no known exploitation of CVE-2025-48879 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48879 and fix it if it is affected.

What it is: CVE-2025-48879 is a medium-severity denial of service vulnerability in OctoPrint, published on 10 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48879 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.11.2
- octoprint (PyPI): affected all versions; fixed in 1.11.2
- OctoPrint (PyPI): affected all versions; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48879/ (Markdown: https://insights.sbomify.com/CVE-2025-48879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48879
- OSV: https://osv.dev/vulnerability/CVE-2025-48879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48879/
Summaries are generated and may contain mistakes; the official description above is the record.
