# CVE-2025-48882: PHPOffice Math allows XXE when processing an XML file in the MathML format

> An attacker can exploit XML External Entity vulnerabilities in PHPOffice Math to read sensitive files or cause denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** GHSA-42hm-pq2f-3r7m

## What is CVE-2025-48882?

CVE-2025-48882 is a high-severity vulnerability in PHPOffice Math, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PHPOffice Math is a library that provides a set of classes to manipulate different formula file formats. Prior to version 0.3.0, loading XML data using the standard `libxml` extension and the `LIBXML_DTDLOAD` flag without additional filtration, leads to XXE. Version 0.3.0 fixes the vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-48882?

2 open source packages ship an affected version, including phpoffice/math.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/math` | Packagist | All versions | 0.3.0 |
| `phpoffice/math` | Packagist | All versions | 0.3.0 |

## How do I fix CVE-2025-48882?

Upgrade phpoffice/math to 0.3.0 or later.

## Is CVE-2025-48882 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48882 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48882 and fix it if it is affected.

What it is: CVE-2025-48882 is a high-severity vulnerability in PHPOffice Math, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48882 exists.

Affected packages and fixed versions:
- phpoffice/math (Packagist): affected all versions; fixed in 0.3.0
- phpoffice/math (Packagist): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48882/ (Markdown: https://insights.sbomify.com/CVE-2025-48882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48882
- OSV: https://osv.dev/vulnerability/CVE-2025-48882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48882/
Summaries are generated and may contain mistakes; the official description above is the record.
