{"answers":{"affected":"2 open source packages ship an affected version, including chrome-php/chrome.","exploited":"There is no known exploitation of CVE-2025-48883 in the wild and no public exploit code.","fix":"Upgrade chrome-php/chrome to 1.14.0 or later.","what":"CVE-2025-48883 is a medium-severity cross-site scripting vulnerability in chrome-php chrome, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-48883 and fix it if it is affected.\n\nWhat it is: CVE-2025-48883 is a medium-severity cross-site scripting vulnerability in chrome-php chrome, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-48883 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- chrome-php/chrome (Packagist): affected all versions; fixed in 1.14.0\n- chrome-php/chrome (Packagist): affected all versions; fixed in 1.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48883/ (Markdown: https://insights.sbomify.com/CVE-2025-48883/index.md)","id":"CVE-2025-48883","markdown":"https://insights.sbomify.com/CVE-2025-48883/index.md","name":"CVE-2025-48883","record":{"aliases":["GHSA-3432-fmrf-7vmh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Chrome automation library","requires_auth":"none","summary":"An attacker can inject malicious scripts via improperly encoded CSS selectors in the Chrome PHP library, potentially executing code in the browser context.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Chrome PHP is missing encoding in `CssSelector`","id":"CVE-2025-48883","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Galette is vulnerable to XSS through Document Type","id":"CVE-2025-48884"},"packages":[{"ecosystem":"Packagist","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"chrome-php/chrome","purl":null,"source":"GHSA-3432-fmrf-7vmh"},{"ecosystem":"Packagist","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"chrome-php/chrome","purl":"pkg:composer/chrome-php/chrome","source":"GHSA-3432-fmrf-7vmh"}],"prev":{"headline":"PHPOffice Math allows XXE when processing an XML file in the MathML format","id":"CVE-2025-48882"},"products":["chrome"],"published":"2025-05-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["chrome-php"]},"summary":"An attacker can inject malicious scripts via improperly encoded CSS selectors in the Chrome PHP library, potentially executing code in the browser context.","url":"https://insights.sbomify.com/CVE-2025-48883/"}