# CVE-2025-48883: Chrome PHP is missing encoding in `CssSelector`

> An attacker can inject malicious scripts via improperly encoded CSS selectors in the Chrome PHP library, potentially executing code in the browser context.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** GHSA-3432-fmrf-7vmh

## What is CVE-2025-48883?

CVE-2025-48883 is a medium-severity cross-site scripting vulnerability in chrome-php chrome, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-48883?

2 open source packages ship an affected version, including chrome-php/chrome.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chrome-php/chrome` | Packagist | All versions | 1.14.0 |
| `chrome-php/chrome` | Packagist | All versions | 1.14.0 |

## How do I fix CVE-2025-48883?

Upgrade chrome-php/chrome to 1.14.0 or later.

## Is CVE-2025-48883 being exploited?

There is no known exploitation of CVE-2025-48883 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48883 and fix it if it is affected.

What it is: CVE-2025-48883 is a medium-severity cross-site scripting vulnerability in chrome-php chrome, published on 30 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48883 in the wild and no public exploit code.

Affected packages and fixed versions:
- chrome-php/chrome (Packagist): affected all versions; fixed in 1.14.0
- chrome-php/chrome (Packagist): affected all versions; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48883/ (Markdown: https://insights.sbomify.com/CVE-2025-48883/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48883
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48883
- OSV: https://osv.dev/vulnerability/CVE-2025-48883

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48883/
Summaries are generated and may contain mistakes; the official description above is the record.
