CVE-2025-48887 vLLM has a Regular Expression Denial of Service (ReDoS, Exponential Complexity) Vulnerability in `pythonic_tool_parser.py`

Medium 6.5 Published Updated

An attacker can cause service unavailability in vLLM by exploiting a Regular Expression Denial of Service vulnerability in the tool parser.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48887?

CVE-2025-48887 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool_parser.py` of versions 0.6.4 up to but excluding 0.9.0. The root cause is the use of a highly complex and nested regular expression for tool call detection, which can be exploited by an attacker to cause severe performance degradation or make the service unavailable. The pattern contains multiple nested quantifiers, optional groups, and inner repetitions which make it vulnerable to catastrophic backtracking. Version 0.9.0 contains a patch for the issue.

Weakness: CWE-1333

Which versions are affected by CVE-2025-48887?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.6.40.9.0
vllm PyPIFrom 0.6.40.9.0
vllm PyPIFrom 0.6.40.9.0

Products include Vllm Vllm.

How do I fix CVE-2025-48887?

Upgrade vllm to 0.9.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-48887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48887 exists.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-w6q7-j642-7c25, PYSEC-2025-50.

Is CVE-2025-48887 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free