{"answers":{"affected":"8 open source packages ship an affected version, including deno and deno_runtime. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48888 exists.","fix":"Upgrade deno to a fixed version for your release line: 2.1.13, 2.2.13 or 2.3.2.","what":"CVE-2025-48888 is a medium-severity vulnerability in denoland deno, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48888 and fix it if it is affected.\n\nWhat it is: CVE-2025-48888 is a medium-severity vulnerability in denoland deno, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48888 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.41.3; fixed in 2.1.13\n- deno (crates.io): affected from 1.41.3; fixed in 2.1.13\n- deno (crates.io): affected from 2.2.0; fixed in 2.2.13\n- deno (crates.io): affected from 2.2.0; fixed in 2.2.13\n- deno (crates.io): affected from 2.3.0; fixed in 2.3.2\n- deno (crates.io): affected from 2.3.0; fixed in 2.3.2\n- deno_runtime (crates.io): affected from 0.150.0; fixed in 0.212.0\n- deno_runtime (crates.io): affected from 0.150.0; fixed in 0.212.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48888/ (Markdown: https://insights.sbomify.com/CVE-2025-48888/index.md)","id":"CVE-2025-48888","markdown":"https://insights.sbomify.com/CVE-2025-48888/index.md","name":"CVE-2025-48888","record":{"aliases":["GHSA-xqxc-x6p3-w683","JLSEC-2026-109"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Deno runtime","requires_auth":"none","summary":"Deno runtime incorrectly allows read access when conflicting allow and deny flags are used, bypassing intended security restrictions.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, `deno run --allow-read --deny-read main.ts` results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as `--allow-* --deny-*`. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deno run with --allow-read and --deny-read flags results in allowed","id":"CVE-2025-48888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":8,"n_references":6,"next":{"headline":"Gradio Allows Unauthorized File Copy via Path Manipulation","id":"CVE-2025-48889"},"packages":[{"ecosystem":"crates.io","fixed":["2.1.13"],"introduced":["1.41.3"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["2.1.13"],"introduced":["1.41.3"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["2.2.13"],"introduced":["2.2.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["2.2.13"],"introduced":["2.2.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["2.3.2"],"introduced":["2.3.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["2.3.2"],"introduced":["2.3.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["0.212.0"],"introduced":["0.150.0"],"last_affected":[],"package":"deno_runtime","purl":null,"source":"GHSA-xqxc-x6p3-w683"},{"ecosystem":"crates.io","fixed":["0.212.0"],"introduced":["0.150.0"],"last_affected":[],"package":"deno_runtime","purl":"pkg:cargo/deno_runtime","source":"GHSA-xqxc-x6p3-w683"}],"prev":{"headline":"vLLM has a Regular Expression Denial of Service (ReDoS, Exponential Complexity) Vulnerability in `pythonic_tool_parser.py`","id":"CVE-2025-48887"},"products":["deno"],"published":"2025-06-04","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["denoland"]},"summary":"Deno runtime incorrectly allows read access when conflicting allow and deny flags are used, bypassing intended security restrictions.","url":"https://insights.sbomify.com/CVE-2025-48888/"}