{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-48920 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-48920 is a high-severity cross-site scripting vulnerability in Drupal etracker, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48920 and fix it if it is affected.\n\nWhat it is: CVE-2025-48920 is a high-severity cross-site scripting vulnerability in Drupal etracker, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48920 in the wild and no public exploit code.\n\nAffected product: Drupal etracker. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48920/ (Markdown: https://insights.sbomify.com/CVE-2025-48920/index.md)","id":"CVE-2025-48920","markdown":"https://insights.sbomify.com/CVE-2025-48920/index.md","name":"CVE-2025-48920","record":{"aliases":["DRUPAL-CONTRIB-2025-074","GHSA-hpgq-7xv5-xf25"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal etracker module","requires_auth":"none","summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Drupal etracker module.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"etracker","vendor":"etracker"}],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal etracker allows Cross-Site Scripting (XSS).This issue affects etracker: from 0.0.0 before 3.1.0.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"etracker - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-074","id":"CVE-2025-48920","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Open Social - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-079","id":"CVE-2025-48921"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"drupal/etracker","purl":"pkg:composer/drupal/etracker?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-074"}],"prev":{"headline":"Simple Klaro - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-073","id":"CVE-2025-48919"},"products":["etracker"],"published":"2025-06-13","related":[{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2010-1543","kev_date_added":null,"published":"2010-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-13","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Drupal etracker module.","url":"https://insights.sbomify.com/CVE-2025-48920/"}