CVE-2025-48924 Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
Attackers can cause application crashes via StackOverflowError by providing very long inputs to ClassUtils.getClass in Apache Commons Lang.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48924?
CVE-2025-48924 is a medium-severity denial of service vulnerability in Apache Commons Lang, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Uncontrolled Recursion vulnerability in Apache Commons Lang.
This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0.
The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Weakness: CWE-674
Which versions are affected by CVE-2025-48924?
4 open source packages ship an affected version, including org.apache.commons:commons-lang3 and commons-lang:commons-lang. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.commons:commons-lang3 Maven | From 3.0 | 3.18.0 |
org.apache.commons:commons-lang3 Maven | From 3.0 | 3.18.0 |
commons-lang:commons-lang Maven | From 2.0 to 2.6 | None |
commons-lang:commons-lang Maven | From 2.0 to 2.6 | None |
Linux distribution packages (36)
apache-commons-compress SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.28.0-150200.3.21.1 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 3.20.0-150200.3.15.2 |
beust-jcommander SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.83-150200.3.15.1 |
google-guice SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 6.0.0-150200.3.13.2 |
guava SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 33.2.1-150200.3.15.1 |
jansi SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 2.4.0-150200.3.9.1 |
maven SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 3.9.16-150200.4.33.1 |
maven-resolver SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.9.27-150200.3.29.1 |
plexus-interpolation SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.27.0-150200.3.9.1 |
plexus-xml SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 3.0.1-150200.5.10.1 |
xmvn SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.3.0-150200.3.30.1 |
xmvn-connector SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.3.0-150200.3.30.1 |
xmvn-mojo SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.3.0-150200.3.30.1 |
xmvn-tools SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.3.0-150200.3.30.1 |
apache-commons-compress SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.28.0-150200.3.21.1 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 3.20.0-150200.3.15.2 |
beust-jcommander SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.83-150200.3.15.1 |
google-guice SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 6.0.0-150200.3.13.2 |
guava SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 33.2.1-150200.3.15.1 |
jansi SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 2.4.0-150200.3.9.1 |
maven SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 3.9.16-150200.4.33.1 |
maven-resolver SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.9.27-150200.3.29.1 |
plexus-interpolation SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.27.0-150200.3.9.1 |
plexus-xml SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 3.0.1-150200.5.10.1 |
xmvn SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.3.0-150200.3.30.1 |
xmvn-connector SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.3.0-150200.3.30.1 |
xmvn-mojo SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.3.0-150200.3.30.1 |
xmvn-tools SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.3.0-150200.3.30.1 |
apache-commons-compress SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.28.0-150200.3.21.1 |
apache-commons-lang3 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 3.20.0-150200.3.15.2 |
beust-jcommander SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.83-150200.3.15.1 |
google-guice SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 6.0.0-150200.3.13.2 |
guava SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 33.2.1-150200.3.15.1 |
jansi SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 2.4.0-150200.3.9.1 |
maven SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 3.9.16-150200.4.33.1 |
maven-resolver SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.9.27-150200.3.29.1 |
Products include Apache Commons Lang.
How do I fix CVE-2025-48924?
Upgrade org.apache.commons:commons-lang3 to 3.18.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-48924 being exploited?
There is no known exploitation of CVE-2025-48924 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as AZL-65144, AZL-65181, CLEANSTART-2026-CK84592, CLEANSTART-2026-CR94528, CLEANSTART-2026-EA81114, CLEANSTART-2026-IF64131 and 107 more.