# CVE-2025-48934: Deno.env.toObject() ignores the variables listed in --deny-env and returns all environment variables

> Attackers can bypass --deny-env restrictions to read all environment variables, including secrets, via Deno.env.toObject().

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2025
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-7w8p-chxq-2789, JLSEC-2026-110

## What is CVE-2025-48934?

CVE-2025-48934 is a medium-severity vulnerability in denoland deno, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Prior to versions 2.1.13 and 2.2.13, the `Deno.env.toObject` method ignores any variables listed in the `--deny-env` option of the `deno run` command. When looking at the documentation of the `--deny-env` option this might lead to a false impression that variables listed in the option are impossible to read. Software relying on the combination of both flags to allow access to most environment variables except a few sensitive ones will be vulnerable to malicious code trying to steal secrets using the `Deno.env.toObject()` method. Versions 2.1.13 and 2.2.13 contains a patch.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-48934?

6 open source packages ship an affected version, including deno and deno_runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 2.1.13 |
| `deno` | crates.io | All versions | 2.1.13 |
| `deno` | crates.io | From 2.2.0 | 2.2.13 |
| `deno` | crates.io | From 2.2.0 | 2.2.13 |
| `deno_runtime` | crates.io | All versions | 0.212.0 |
| `deno_runtime` | crates.io | All versions | 0.212.0 |

Products: Deno Deno.

## How do I fix CVE-2025-48934?

Upgrade deno to a fixed version for your release line: 2.1.13 or 2.2.13.

## Is CVE-2025-48934 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48934 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48934 and fix it if it is affected.

What it is: CVE-2025-48934 is a medium-severity vulnerability in denoland deno, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48934 exists.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 2.1.13
- deno (crates.io): affected all versions; fixed in 2.1.13
- deno (crates.io): affected from 2.2.0; fixed in 2.2.13
- deno (crates.io): affected from 2.2.0; fixed in 2.2.13
- deno_runtime (crates.io): affected all versions; fixed in 0.212.0
- deno_runtime (crates.io): affected all versions; fixed in 0.212.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48934/ (Markdown: https://insights.sbomify.com/CVE-2025-48934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48934
- OSV: https://osv.dev/vulnerability/CVE-2025-48934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48934/
Summaries are generated and may contain mistakes; the official description above is the record.
