# CVE-2025-48937: matrix-sdk-crypto vulnerable to sender of encrypted events being spoofed by homeserver administrator

> A malicious homeserver can spoof the sender of encrypted events, allowing impersonation of other users in Matrix clients using the vulnerable library.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-x958-rvg6-956w, RUSTSEC-2025-0041, openSUSE-SU-2025:15218-1

## What is CVE-2025-48937?

CVE-2025-48937 is a medium-severity authentication bypass vulnerability in matrix-org matrix-rust-sdk, published on 10 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

matrix-rust-sdk is an implementation of a Matrix client-server library in Rust. matrix-sdk-crypto since version 0.8.0 and up to 0.11.0 does not correctly validate the sender of an encrypted event. Accordingly, a malicious homeserver operator can modify events served to clients, making those events appear to the recipient as if they were sent by another user. This vulnerability is fixed in 0.11.1 and 0.12.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-48937?

3 open source packages ship an affected version, including matrix-sdk-crypto.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-sdk-crypto` | crates.io | From 0.8.0 | 0.11.1 |
| `matrix-sdk-crypto` | crates.io | From 0.8.0 | 0.11.1 |
| `matrix-sdk-crypto` | crates.io | From 0.8.0 | 0.11.1 |
| `fractal` | openSUSE:Tumbleweed | All versions | 11.2-1.1 |

## How do I fix CVE-2025-48937?

Upgrade matrix-sdk-crypto to 0.11.1 or later.

## Is CVE-2025-48937 being exploited?

There is no known exploitation of CVE-2025-48937 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48937 and fix it if it is affected.

What it is: CVE-2025-48937 is a medium-severity authentication bypass vulnerability in matrix-org matrix-rust-sdk, published on 10 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48937 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-sdk-crypto (crates.io): affected from 0.8.0; fixed in 0.11.1
- matrix-sdk-crypto (crates.io): affected from 0.8.0; fixed in 0.11.1
- matrix-sdk-crypto (crates.io): affected from 0.8.0; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48937/ (Markdown: https://insights.sbomify.com/CVE-2025-48937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48937
- OSV: https://osv.dev/vulnerability/CVE-2025-48937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48937/
Summaries are generated and may contain mistakes; the official description above is the record.
