# CVE-2025-48938: Prevent GitHub CLI and extensions from executing arbitrary commands from compromised GitHub Enterprise Server

> A compromised GitHub Enterprise Server can execute arbitrary commands on a user's machine via the go-gh library by manipulating URLs.

- **Severity:** Low 2.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** AZL-62282, DEBIAN-CVE-2025-48938, GHSA-g9f5-x53j-h563, GO-2025-3732, UBUNTU-CVE-2025-48938

## What is CVE-2025-48938?

CVE-2025-48938 is a low-severity command injection vulnerability in cli go-gh, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

go-gh is a collection of Go modules to make authoring GitHub CLI extensions easier. A security vulnerability has been identified in versions prior to 2.12.1 where an attacker-controlled GitHub Enterprise Server could result in executing arbitrary commands on a user's machine by replacing HTTP URLs provided by GitHub with local file paths for browsing. In `2.12.1`, `Browser.Browse()` has been enhanced to allow and disallow a variety of scenarios to avoid opening or executing files on the filesystem without unduly impacting HTTP URLs. No known workarounds are available other than upgrading.

Weakness: CWE-501 (Trust Boundary Violation)

## Which versions are affected by CVE-2025-48938?

3 open source packages ship an affected version, including github.com/cli/go-gh/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cli/go-gh/v2` | Go | All versions | 2.12.1 |
| `github.com/cli/go-gh/v2` | Go | All versions | 2.12.1 |
| `github.com/cli/go-gh/v2` | Go | All versions | 2.12.1 |

Products: Cli Go-Gh.

## How do I fix CVE-2025-48938?

Upgrade github.com/cli/go-gh/v2 to 2.12.1 or later.

## Is CVE-2025-48938 being exploited?

There is no known exploitation of CVE-2025-48938 in the wild and no public exploit code.

## Other vulnerabilities in cli go-gh

- [CVE-2024-53859](https://insights.sbomify.com/CVE-2024-53859/): go-gh `auth.TokenForHost` violates GitHub host security boundary within a codespace (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48938 and fix it if it is affected.

What it is: CVE-2025-48938 is a low-severity command injection vulnerability in cli go-gh, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48938 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cli/go-gh/v2 (Go): affected all versions; fixed in 2.12.1
- github.com/cli/go-gh/v2 (Go): affected all versions; fixed in 2.12.1
- github.com/cli/go-gh/v2 (Go): affected all versions; fixed in 2.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48938/ (Markdown: https://insights.sbomify.com/CVE-2025-48938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48938
- OSV: https://osv.dev/vulnerability/CVE-2025-48938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48938/
Summaries are generated and may contain mistakes; the official description above is the record.
