# CVE-2025-48939: tarteaucitron.js vulnerable to DOM Clobbering via document.currentScript

> An attacker can manipulate DOM elements to alter the script's CDN domain, potentially bypassing security controls or causing script loading failures.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jul 2025
- **Updated:** 3 Jul 2025
- **Also known as:** GHSA-q43x-79jr-cq98

## What is CVE-2025-48939?

CVE-2025-48939 is a medium-severity vulnerability in AmauriC tarteaucitron.js, published on 3 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

tarteaucitron.js is a compliant and accessible cookie banner. Prior to version 1.22.0, a vulnerability was identified in tarteaucitron.js where document.currentScript was accessed without verifying that it referenced an actual <script> element. If an attacker injected an HTML element, it could clobber the document.currentScript property. This causes the script to resolve incorrectly to an element instead of the <script> tag, leading to unexpected behavior or failure to load the script path correctly. This issue arises because in some browser environments, named DOM elements become properties on the global document object. An attacker with control over the HTML could exploit this to change the CDN domain of tarteaucitron. This issue has been patched in version 1.22.0.

Weakness: CWE-138 (Improper Neutralization of Special Elements)

## Which versions are affected by CVE-2025-48939?

2 open source packages ship an affected version, including tarteaucitronjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tarteaucitronjs` | npm | All versions | 1.22.0 |
| `tarteaucitronjs` | npm | All versions | 1.22.0 |

Products: Amauri Tarteaucitronjs.

## How do I fix CVE-2025-48939?

Upgrade tarteaucitronjs to 1.22.0 or later.

## Is CVE-2025-48939 being exploited?

There is no known exploitation of CVE-2025-48939 in the wild and no public exploit code.

## Other vulnerabilities in AmauriC tarteaucitron.js

- [CVE-2025-31138](https://insights.sbomify.com/CVE-2025-31138/): tarteaucitron.js allows UI manipulation via unrestricted CSS injection (medium 5.5)
- [CVE-2025-31475](https://insights.sbomify.com/CVE-2025-31475/): tarteaucitron.js allows prototype pollution via custom text injection (medium 5.5)
- [CVE-2025-31476](https://insights.sbomify.com/CVE-2025-31476/): tarteaucitron.js allows url scheme injection via unfiltered inputs (medium 4.8)
- [CVE-2026-22809](https://insights.sbomify.com/CVE-2026-22809/): tarteaucitron.js has Regular Expression Denial of Service (ReDoS) vulnerability (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48939 and fix it if it is affected.

What it is: CVE-2025-48939 is a medium-severity vulnerability in AmauriC tarteaucitron.js, published on 3 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48939 in the wild and no public exploit code.

Affected packages and fixed versions:
- tarteaucitronjs (npm): affected all versions; fixed in 1.22.0
- tarteaucitronjs (npm): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48939/ (Markdown: https://insights.sbomify.com/CVE-2025-48939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48939
- OSV: https://osv.dev/vulnerability/CVE-2025-48939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48939/
Summaries are generated and may contain mistakes; the official description above is the record.
