{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48942 exists.","fix":"Upgrade vllm to 0.9.0 or later.","what":"CVE-2025-48942 is a medium-severity vulnerability in Vllm Vllm, published on 30 May 2025."},"fix_prompt":"Check this codebase for CVE-2025-48942 and fix it if it is affected.\n\nWhat it is: CVE-2025-48942 is a medium-severity vulnerability in Vllm Vllm, published on 30 May 2025. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48942 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.8.0; fixed in 0.9.0\n- vllm (PyPI): affected from 0.8.0; fixed in 0.9.0\n- vllm (PyPI): affected from 0.8.0; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48942/ (Markdown: https://insights.sbomify.com/CVE-2025-48942/index.md)","id":"CVE-2025-48942","markdown":"https://insights.sbomify.com/CVE-2025-48942/index.md","name":"CVE-2025-48942","record":{"aliases":["GHSA-6qc9-v4r8-22xg","PYSEC-2025-54"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the  /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vLLM DOS: Remotely kill vllm over http with invalid JSON schema","id":"CVE-2025-48942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":null,"year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"vLLM allows clients to crash the openai server with invalid regex","id":"CVE-2025-48943"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0.8.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-6qc9-v4r8-22xg"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0.8.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-6qc9-v4r8-22xg"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0.8.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2025-54"}],"prev":{"headline":"MyBB may disclosure unviewable threads' titles in searches","id":"CVE-2025-48941"},"products":["vllm"],"published":"2025-05-30","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["vllm-project"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-48942/"}