# CVE-2025-48942: vLLM DOS: Remotely kill vllm over http with invalid JSON schema


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** GHSA-6qc9-v4r8-22xg, PYSEC-2025-54

## What is CVE-2025-48942?

CVE-2025-48942 is a medium-severity vulnerability in Vllm Vllm, published on 30 May 2025. 

### Official description

vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the  /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-48942?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.8.0 | 0.9.0 |
| `vllm` | PyPI | From 0.8.0 | 0.9.0 |
| `vllm` | PyPI | From 0.8.0 | 0.9.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-48942?

Upgrade vllm to 0.9.0 or later.

## Is CVE-2025-48942 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48942 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48942 and fix it if it is affected.

What it is: CVE-2025-48942 is a medium-severity vulnerability in Vllm Vllm, published on 30 May 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48942 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.8.0; fixed in 0.9.0
- vllm (PyPI): affected from 0.8.0; fixed in 0.9.0
- vllm (PyPI): affected from 0.8.0; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48942/ (Markdown: https://insights.sbomify.com/CVE-2025-48942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48942
- OSV: https://osv.dev/vulnerability/CVE-2025-48942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48942/
Summaries are generated and may contain mistakes; the official description above is the record.
