CVE-2025-48947 NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies
Attackers can steal session cookies via CDN caching if Cache-Control headers are missing, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-48947?
CVE-2025-48947 is a high-severity vulnerability in nextjs-auth0, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.
Weakness: CWE-525
Which versions are affected by CVE-2025-48947?
2 open source packages ship an affected version, including @auth0/nextjs-auth0.
| Package | Affected | Fixed in |
|---|---|---|
@auth0/nextjs-auth0 npm | From 4.0.1 | 4.6.1 |
@auth0/nextjs-auth0 npm | From 4.0.1 | 4.6.1 |
How do I fix CVE-2025-48947?
Upgrade @auth0/nextjs-auth0 to 4.6.1 or later.
Is CVE-2025-48947 being exploited?
There is no known exploitation of CVE-2025-48947 in the wild and no public exploit code.
Sources
Also known as GHSA-f3fg-mf2q-fj3f.