{"answers":{"affected":"2 open source packages ship an affected version, including @auth0/nextjs-auth0.","exploited":"There is no known exploitation of CVE-2025-48947 in the wild and no public exploit code.","fix":"Upgrade @auth0/nextjs-auth0 to 4.6.1 or later.","what":"CVE-2025-48947 is a high-severity vulnerability in nextjs-auth0, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-48947 and fix it if it is affected.\n\nWhat it is: CVE-2025-48947 is a high-severity vulnerability in nextjs-auth0, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-48947 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.6.1\n- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48947/ (Markdown: https://insights.sbomify.com/CVE-2025-48947/index.md)","id":"CVE-2025-48947","markdown":"https://insights.sbomify.com/CVE-2025-48947/index.md","name":"CVE-2025-48947","record":{"aliases":["GHSA-f3fg-mf2q-fj3f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js Auth0 SDK","requires_auth":"none","summary":"Attackers can steal session cookies via CDN caching if Cache-Control headers are missing, potentially leading to account takeover.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-525","name":"Use of Web Browser Cache Containing Sensitive Information"}],"description":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies","id":"CVE-2025-48947","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Navidrome Transcoding Permission Bypass Vulnerability Report","id":"CVE-2025-48948"},"packages":[{"ecosystem":"npm","fixed":["4.6.1"],"introduced":["4.0.1"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":null,"source":"GHSA-f3fg-mf2q-fj3f"},{"ecosystem":"npm","fixed":["4.6.1"],"introduced":["4.0.1"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":"pkg:npm/%40auth0/nextjs-auth0","source":"GHSA-f3fg-mf2q-fj3f"}],"prev":{"headline":"liboqs affected by theoretical design flaw in HQC","id":"CVE-2025-48946"},"products":["nextjs-auth0"],"published":"2025-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["auth0"]},"summary":"Attackers can steal session cookies via CDN caching if Cache-Control headers are missing, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2025-48947/"}