# CVE-2025-48947: NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies

> Attackers can steal session cookies via CDN caching if Cache-Control headers are missing, potentially leading to account takeover.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2025
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-f3fg-mf2q-fj3f

## What is CVE-2025-48947?

CVE-2025-48947 is a high-severity vulnerability in nextjs-auth0, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.

Weakness: CWE-525 (Use of Web Browser Cache Containing Sensitive Information)

## Which versions are affected by CVE-2025-48947?

2 open source packages ship an affected version, including @auth0/nextjs-auth0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@auth0/nextjs-auth0` | npm | From 4.0.1 | 4.6.1 |
| `@auth0/nextjs-auth0` | npm | From 4.0.1 | 4.6.1 |

## How do I fix CVE-2025-48947?

Upgrade @auth0/nextjs-auth0 to 4.6.1 or later.

## Is CVE-2025-48947 being exploited?

There is no known exploitation of CVE-2025-48947 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48947 and fix it if it is affected.

What it is: CVE-2025-48947 is a high-severity vulnerability in nextjs-auth0, published on 4 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-48947 in the wild and no public exploit code.

Affected packages and fixed versions:
- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.6.1
- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48947/ (Markdown: https://insights.sbomify.com/CVE-2025-48947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48947
- OSV: https://osv.dev/vulnerability/CVE-2025-48947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48947/
Summaries are generated and may contain mistakes; the official description above is the record.
