# CVE-2025-48948: Navidrome Transcoding Permission Bypass Vulnerability Report

> Authenticated users can bypass authorization to modify administrator-only transcoding settings in Navidrome when transcoding is enabled.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** GHSA-f238-rggp-82m3, GO-2025-3733

## What is CVE-2025-48948?

CVE-2025-48948 is a high-severity missing authorization vulnerability in navidrome, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Navidrome is an open source web-based music collection server and streamer. A permission verification flaw in versions prior to 0.56.0 allows any authenticated regular user to bypass authorization checks and perform administrator-only transcoding configuration operations, including creating, modifying, and deleting transcoding settings. In the threat model where administrators are trusted but regular users are not, this vulnerability represents a significant security risk when transcoding is enabled. Version 0.56.0 patches the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-48948?

3 open source packages ship an affected version, including github.com/navidrome/navidrome. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/navidrome/navidrome` | Go | All versions | 0.56.0 |
| `github.com/navidrome/navidrome` | Go | All versions | 0.56.0 |
| `github.com/navidrome/navidrome` | Go | All versions | 0.56.0 |

Products: Navidrome Navidrome.

## How do I fix CVE-2025-48948?

Upgrade github.com/navidrome/navidrome to 0.56.0 or later.

## Is CVE-2025-48948 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48948 exists.

## Other vulnerabilities in navidrome

- [CVE-2024-47062](https://insights.sbomify.com/CVE-2024-47062/): Multiple SQL Injections and ORM Leak in navidrome (critical 9.4)
- [CVE-2026-25579](https://insights.sbomify.com/CVE-2026-25579/): Navidrome affected by Denial of Service and disk exhaustion via oversized `size` parameter in `/rest/getCoverArt` and `/share/img/<token>` endpoints (critical 9.2)
- [CVE-2024-41259](https://insights.sbomify.com/CVE-2024-41259/): Navidrome uses MD5 hashing algorithm (critical 9.1)
- [CVE-2025-48949](https://insights.sbomify.com/CVE-2025-48949/): Navidrome allows SQL Injection via role parameter (high 8.9)
- [CVE-2023-51442](https://insights.sbomify.com/CVE-2023-51442/): Authentication bypass vulnerability in navidrome's subsonic endpoint (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48948 and fix it if it is affected.

What it is: CVE-2025-48948 is a high-severity missing authorization vulnerability in navidrome, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48948 exists.

Affected packages and fixed versions:
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.56.0
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.56.0
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.56.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48948/ (Markdown: https://insights.sbomify.com/CVE-2025-48948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48948
- OSV: https://osv.dev/vulnerability/CVE-2025-48948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48948/
Summaries are generated and may contain mistakes; the official description above is the record.
