{"answers":{"affected":"2 open source packages ship an affected version, including auth0/auth0-php.","exploited":"There is no known exploitation of CVE-2025-48951 in the wild and no public exploit code.","fix":"Upgrade auth0/auth0-php to 8.3.1 or later.","what":"CVE-2025-48951 is a critical unsafe deserialization vulnerability in auth0-PHP, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48951 and fix it if it is affected.\n\nWhat it is: CVE-2025-48951 is a critical unsafe deserialization vulnerability in auth0-PHP, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48951 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/auth0-php (Packagist): affected from 8.0.0-BETA3; fixed in 8.3.1\n- auth0/auth0-php (Packagist): affected from 8.0.0-BETA3; fixed in 8.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48951/ (Markdown: https://insights.sbomify.com/CVE-2025-48951/index.md)","id":"CVE-2025-48951","markdown":"https://insights.sbomify.com/CVE-2025-48951/index.md","name":"CVE-2025-48951","record":{"aliases":["GHSA-v9m8-9xxp-q492"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Auth0 SDK","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the Auth0-PHP SDK.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth0-PHP SDK Deserialization of Untrusted Data vulnerability","id":"CVE-2025-48951","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"NetAlertX has Password Bypass Vulnerability due to Loose Comparison in PHP","id":"CVE-2025-48952"},"packages":[{"ecosystem":"Packagist","fixed":["8.3.1"],"introduced":["8.0.0-BETA3"],"last_affected":[],"package":"auth0/auth0-php","purl":null,"source":"GHSA-v9m8-9xxp-q492"},{"ecosystem":"Packagist","fixed":["8.3.1"],"introduced":["8.0.0-BETA3"],"last_affected":[],"package":"auth0/auth0-php","purl":"pkg:composer/auth0/auth0-php","source":"GHSA-v9m8-9xxp-q492"}],"prev":{"headline":"MaxKB Python Sandbox Bypass in Function Library","id":"CVE-2025-48950"},"products":["auth0-PHP"],"published":"2025-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["auth0"]},"summary":"Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the Auth0-PHP SDK.","url":"https://insights.sbomify.com/CVE-2025-48951/"}