# CVE-2025-48951: Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

> Attackers can execute arbitrary code by sending malicious serialized data in cookies to applications using the Auth0-PHP SDK.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2025
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-v9m8-9xxp-q492

## What is CVE-2025-48951?

CVE-2025-48951 is a critical unsafe deserialization vulnerability in auth0-PHP, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-48951?

2 open source packages ship an affected version, including auth0/auth0-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/auth0-php` | Packagist | From 8.0.0-BETA3 | 8.3.1 |
| `auth0/auth0-php` | Packagist | From 8.0.0-BETA3 | 8.3.1 |

## How do I fix CVE-2025-48951?

Upgrade auth0/auth0-php to 8.3.1 or later.

## Is CVE-2025-48951 being exploited?

There is no known exploitation of CVE-2025-48951 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48951 and fix it if it is affected.

What it is: CVE-2025-48951 is a critical unsafe deserialization vulnerability in auth0-PHP, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48951 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/auth0-php (Packagist): affected from 8.0.0-BETA3; fixed in 8.3.1
- auth0/auth0-php (Packagist): affected from 8.0.0-BETA3; fixed in 8.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48951/ (Markdown: https://insights.sbomify.com/CVE-2025-48951/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48951
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48951
- OSV: https://osv.dev/vulnerability/CVE-2025-48951

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48951/
Summaries are generated and may contain mistakes; the official description above is the record.
