# CVE-2025-48954: Discourse vulnerable to XSS via user-provided query parameter in oauth failure flow

> Attackers can execute arbitrary scripts via OAuth failure parameters if Content Security Policy is disabled, potentially compromising user accounts.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2025
- **Updated:** 25 Jun 2025
- **Also known as:** BIT-discourse-2025-48954, GHSA-26p5-mjjh-wfcf

## What is CVE-2025-48954?

CVE-2025-48954 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Discourse is an open-source discussion platform. Versions prior to 3.5.0.beta6 are vulnerable to cross-site scripting when the content security policy isn't enabled when using social logins. Version 3.5.0.beta6 patches the issue. As a workaround, have the content security policy enabled.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-48954?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.5.0 |

Products: Discourse Discourse.

## How do I fix CVE-2025-48954?

Upgrade discourse to 3.5.0 or later.

## Is CVE-2025-48954 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48954 exists.

Public exploit code:

- Discourse OAuth Social Login - Cross-site Scripting (nuclei): http/cves/2025/CVE-2025-48954.yaml

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48954 and fix it if it is affected.

What it is: CVE-2025-48954 is a high-severity cross-site scripting vulnerability in Discourse Discourse, published on 25 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48954 exists.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48954/ (Markdown: https://insights.sbomify.com/CVE-2025-48954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48954
- OSV: https://osv.dev/vulnerability/CVE-2025-48954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48954/
Summaries are generated and may contain mistakes; the official description above is the record.
