CVE-2025-48956 vLLM API endpoints vulnerable to Denial of Service Attacks

High 7.5 Published Updated

Remote attackers can crash the vLLM server by sending oversized HTTP headers, causing memory exhaustion without authentication.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48956?

CVE-2025-48956 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.

Weakness: CWE-400

Which versions are affected by CVE-2025-48956?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.1.00.10.1.1
vllm PyPIFrom 0.1.00.10.1.1
vllm PyPIFrom 0.1.00.10.1.1

Products include Vllm Vllm.

How do I fix CVE-2025-48956?

Upgrade vllm to 0.10.1.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-48956 being exploited?

There is no known exploitation of CVE-2025-48956 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-rxc4-3w6r-4v47, PYSEC-2026-2021.

Is CVE-2025-48956 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free