{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-48956 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.10.1.1 or later.","what":"CVE-2025-48956 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48956 and fix it if it is affected.\n\nWhat it is: CVE-2025-48956 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48956 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.1.0; fixed in 0.10.1.1\n- vllm (PyPI): affected from 0.1.0; fixed in 0.10.1.1\n- vllm (PyPI): affected from 0.1.0; fixed in 0.10.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48956/ (Markdown: https://insights.sbomify.com/CVE-2025-48956/index.md)","id":"CVE-2025-48956","markdown":"https://insights.sbomify.com/CVE-2025-48956/index.md","name":"CVE-2025-48956","record":{"aliases":["GHSA-rxc4-3w6r-4v47","PYSEC-2026-2021"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"Remote attackers can crash the vLLM server by sending oversized HTTP headers, causing memory exhaustion without authentication.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM API endpoints vulnerable to Denial of Service Attacks","id":"CVE-2025-48956","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"AstrBot Has Path Traversal Vulnerability in /api/chat/get_file","id":"CVE-2025-48957"},"packages":[{"ecosystem":"PyPI","fixed":["0.10.1.1"],"introduced":["0.1.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-rxc4-3w6r-4v47"},{"ecosystem":"PyPI","fixed":["0.10.1.1"],"introduced":["0.1.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-rxc4-3w6r-4v47"},{"ecosystem":"PyPI","fixed":["0.10.1.1"],"introduced":["0.1.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2021"}],"prev":{"headline":"Para Server Logs Sensitive Information","id":"CVE-2025-48955"},"products":["vllm"],"published":"2025-08-21","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-21","vendors":["vllm-project"]},"summary":"Remote attackers can crash the vLLM server by sending oversized HTTP headers, causing memory exhaustion without authentication.","url":"https://insights.sbomify.com/CVE-2025-48956/"}