# CVE-2025-48956: vLLM API endpoints vulnerable to Denial of Service Attacks

> Remote attackers can crash the vLLM server by sending oversized HTTP headers, causing memory exhaustion without authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-rxc4-3w6r-4v47, PYSEC-2026-2021

## What is CVE-2025-48956?

CVE-2025-48956 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-48956?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.1.0 | 0.10.1.1 |
| `vllm` | PyPI | From 0.1.0 | 0.10.1.1 |
| `vllm` | PyPI | From 0.1.0 | 0.10.1.1 |

Products: Vllm Vllm.

## How do I fix CVE-2025-48956?

Upgrade vllm to 0.10.1.1 or later.

## Is CVE-2025-48956 being exploited?

There is no known exploitation of CVE-2025-48956 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48956 and fix it if it is affected.

What it is: CVE-2025-48956 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48956 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.1.0; fixed in 0.10.1.1
- vllm (PyPI): affected from 0.1.0; fixed in 0.10.1.1
- vllm (PyPI): affected from 0.1.0; fixed in 0.10.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48956/ (Markdown: https://insights.sbomify.com/CVE-2025-48956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48956
- OSV: https://osv.dev/vulnerability/CVE-2025-48956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48956/
Summaries are generated and may contain mistakes; the official description above is the record.
