{"answers":{"affected":"3 open source packages ship an affected version, including astrbot. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48957 exists.","fix":"Upgrade astrbot to 3.5.13 or later.","what":"CVE-2025-48957 is a high-severity path traversal vulnerability in AstrBotDevs AstrBot, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48957 and fix it if it is affected.\n\nWhat it is: CVE-2025-48957 is a high-severity path traversal vulnerability in AstrBotDevs AstrBot, published on 2 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48957 exists.\n\nAffected packages and fixed versions:\n- astrbot (PyPI): affected from 3.4.4; fixed in 3.5.13\n- astrbot (PyPI): affected from 3.4.4; fixed in 3.5.13\n- astrbot (PyPI): affected from 3.4.4; fixed in 3.5.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48957/ (Markdown: https://insights.sbomify.com/CVE-2025-48957/index.md)","id":"CVE-2025-48957","markdown":"https://insights.sbomify.com/CVE-2025-48957/index.md","name":"CVE-2025-48957","record":{"aliases":["GHSA-cq37-g2qp-3c2p","PYSEC-2026-1196"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM chatbot framework","requires_auth":"none","summary":"Attackers can exploit a path traversal flaw in the file retrieval API to access sensitive configuration data like API keys and passwords.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"astrbot","vendor":"astrbot"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"AstrBot is a large language model chatbot and development framework. A path traversal vulnerability present in versions 3.4.4 through 3.5.12 may lead to information disclosure, such as API keys for LLM providers, account passwords, and other sensitive data. The vulnerability has been addressed in Pull Request #1676 and is included in version 3.5.13. As a workaround, users can edit the `cmd_config.json` file to disable the dashboard feature as a temporary workaround. However, it is strongly recommended to upgrade to version v3.5.13 or later to fully resolve this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"AstrBot Has Path Traversal Vulnerability in /api/chat/get_file","id":"CVE-2025-48957","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"Froxlor has an HTML Injection Vulnerability","id":"CVE-2025-48958"},"packages":[{"ecosystem":"PyPI","fixed":["3.5.13"],"introduced":["3.4.4"],"last_affected":[],"package":"astrbot","purl":null,"source":"GHSA-cq37-g2qp-3c2p"},{"ecosystem":"PyPI","fixed":["3.5.13"],"introduced":["3.4.4"],"last_affected":[],"package":"astrbot","purl":"pkg:pypi/astrbot","source":"GHSA-cq37-g2qp-3c2p"},{"ecosystem":"PyPI","fixed":["3.5.13"],"introduced":["3.4.4"],"last_affected":[],"package":"astrbot","purl":"pkg:pypi/astrbot","source":"PYSEC-2026-1196"}],"prev":{"headline":"vLLM API endpoints vulnerable to Denial of Service Attacks","id":"CVE-2025-48956"},"products":["AstrBot"],"published":"2025-06-02","related":[{"cvss_score":7.5,"headline":"AstrBot contains a directory traversal vulnerability","id":"CVE-2025-57698","kev_date_added":null,"published":"2025-11-07"},{"cvss_score":7.3,"headline":"AstrBot is vulnerable to RCE with hard-coded JWT signing keys","id":"CVE-2025-55449","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":6.5,"headline":"AstrBot has an arbitrary file read vulnerability in function _encode_image_bs64","id":"CVE-2025-57697","kev_date_added":null,"published":"2025-11-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["AstrBotDevs"]},"summary":"Attackers can exploit a path traversal flaw in the file retrieval API to access sensitive configuration data like API keys and passwords.","url":"https://insights.sbomify.com/CVE-2025-48957/"}