# CVE-2025-48958: Froxlor has an HTML Injection Vulnerability

> Attackers can inject malicious HTML into the customer portal email section to perform phishing and steal credentials without authentication.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2025
- **Updated:** 2 Jun 2025
- **Also known as:** GHSA-26xq-m8xw-6373

## What is CVE-2025-48958?

CVE-2025-48958 is a medium-severity cross-site scripting vulnerability in Froxlor, published on 2 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Froxlor is open source server administration software. Prior to version 2.2.6, an HTML Injection vulnerability in the customer account portal allows an attacker to inject malicious HTML payloads in the email section. This can lead to phishing attacks, credential theft, and reputational damage by redirecting users to malicious external websites. The vulnerability has a medium severity, as it can be exploited through user input without authentication. Version 2.2.6 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-48958?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.2.6 |
| `froxlor/froxlor` | Packagist | All versions | 2.2.6 |

Products: Froxlor Froxlor.

## How do I fix CVE-2025-48958?

Upgrade froxlor/froxlor to 2.2.6 or later.

## Is CVE-2025-48958 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48958 exists.

## Other vulnerabilities in Froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48958 and fix it if it is affected.

What it is: CVE-2025-48958 is a medium-severity cross-site scripting vulnerability in Froxlor, published on 2 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-48958 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.2.6
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48958/ (Markdown: https://insights.sbomify.com/CVE-2025-48958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48958
- OSV: https://osv.dev/vulnerability/CVE-2025-48958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48958/
Summaries are generated and may contain mistakes; the official description above is the record.
