CVE-2025-48977 Apache Ignite: REST HTTP arbitrary file read vulnerability

High 8.5 Published Updated

Authenticated users can read arbitrary files on the server via a path traversal flaw in the Apache Ignite REST API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48977?

CVE-2025-48977 is a high-severity path traversal vulnerability in Apache Ignite, published on 28 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Relative Path Traversal vulnerability in Apache Ignite REST API.

Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0.

Users are recommended to upgrade to version 2.18.0, which fixes the issue.

Weakness: CWE-23

Which versions are affected by CVE-2025-48977?

2 open source packages ship an affected version, including org.apache.ignite:ignite-core. It affects 1 product.

PackageAffectedFixed in
org.apache.ignite:ignite-core MavenFrom 2.0.02.18.0
org.apache.ignite:ignite-core MavenFrom 2.0.02.18.0

Products include Apache Ignite.

How do I fix CVE-2025-48977?

Upgrade org.apache.ignite:ignite-core to 2.18.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-48977 being exploited?

There is no known exploitation of CVE-2025-48977 in the wild and no public exploit code.

Sources

Also known as GHSA-v45h-mqf4-6939, MINI-4rpr-v3j5-wf4w, MINI-c3w7-56h3-8g44.

Is CVE-2025-48977 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free