CVE-2025-48988 Apache Tomcat: FileUpload large number of parts with headers DoS
Attackers can cause denial of service in Apache Tomcat by sending file uploads with a large number of parts and headers, exhausting server resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48988?
CVE-2025-48988 is a high-severity denial of service vulnerability in Apache Tomcat, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Weakness: CWE-770
Which versions are affected by CVE-2025-48988?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.106 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.106 |
tomcat Bitnami | All versions | 9.0.106, 10.1.42, 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.106 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.106 |
Products include Apache Tomcat.
How do I fix CVE-2025-48988?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-48988 being exploited?
There is no known exploitation of CVE-2025-48988 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-48988, CLSA-2026-1775521833, CLSA-2026-1784682930, DEBIAN-CVE-2025-48988, GHSA-h3gc-qfqq-6h8f, ROOT-APP-MAVEN-CVE-2025-48988 and 1 more.