CVE-2025-48989 Apache Tomcat: h2 DoS - Made You Reset
Attackers can cause a denial of service in Apache Tomcat via improper resource shutdown, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-48989?
CVE-2025-48989 is a high-severity denial of service vulnerability in Apache Tomcat, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected.
Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.
Weakness: CWE-404
Which versions are affected by CVE-2025-48989?
13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.44 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.44 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.10 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.10 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.108 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.108 |
7 more packages
tomcat Bitnami | All versions | 9.0.108, 10.1.44, 11.0.10 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.44 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.44 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.10 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.10 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0.M1 | 9.0.108 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0.M1 | 9.0.108 |
Linux distribution packages (13)
tomcat10 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 10.1.44-150200.5.51.1 |
tomcat10 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 10.1.44-150200.5.51.1 |
tomcat10 SUSE:Linux Enterprise Module for Web and Scripting 15 SP6 | All versions | 10.1.44-150200.5.51.1 |
tomcat11 SUSE:Linux Enterprise Module for Web and Scripting 15 SP6 | All versions | 11.0.10-150600.13.9.1 |
tomcat10 SUSE:Linux Enterprise Module for Web and Scripting 15 SP7 | All versions | 10.1.44-150200.5.51.1 |
tomcat11 SUSE:Linux Enterprise Module for Web and Scripting 15 SP7 | All versions | 11.0.10-150600.13.9.1 |
tomcat10 SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 10.1.44-150200.5.51.1 |
tomcat10 SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 10.1.44-150200.5.51.1 |
tomcat10 openSUSE:Leap 15.6 | All versions | 10.1.44-150200.5.51.1 |
tomcat11 openSUSE:Leap 15.6 | All versions | 11.0.10-150600.13.9.1 |
tomcat openSUSE:Tumbleweed | All versions | 9.0.108-1.1 |
tomcat10 openSUSE:Tumbleweed | All versions | 10.1.44-1.1 |
tomcat11 openSUSE:Tumbleweed | All versions | 11.0.10-1.1 |
Products include Apache Tomcat.
How do I fix CVE-2025-48989?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.44, 11.0.10 or 9.0.108.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-48989 being exploited?
There is no known exploitation of CVE-2025-48989 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-48989, CLSA-2025-1757011448, CLSA-2025-1761005194, CLSA-2026-1773101695, CLSA-2026-1786443758, DEBIAN-CVE-2025-48989 and 14 more.