CVE-2025-48997 Multer vulnerable to Denial of Service via unhandled exception

High 8.7 Published Updated

An attacker can crash the application by sending a multipart upload with an empty field name, causing an unhandled exception.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-48997?

CVE-2025-48997 is a high-severity denial of service vulnerability in expressjs multer, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to `2.0.1` to receive a patch. No known workarounds are available.

Weakness: CWE-248

Which versions are affected by CVE-2025-48997?

2 open source packages ship an affected version, including multer.

PackageAffectedFixed in
multer npmFrom 1.4.4-lts.12.0.1
multer npmFrom 1.4.4-lts.12.0.1

How do I fix CVE-2025-48997?

Upgrade multer to 2.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-48997 being exploited?

There is no known exploitation of CVE-2025-48997 in the wild and no public exploit code.

Sources

Also known as ECHO-05c8-97e7-5c87, GHSA-g5hg-p3ph-g8qg, MINI-qmch-926m-x8qr, ROOT-APP-NPM-CVE-2025-48997.

Is CVE-2025-48997 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free