{"answers":{"affected":"2 open source packages ship an affected version, including multer.","exploited":"There is no known exploitation of CVE-2025-48997 in the wild and no public exploit code.","fix":"Upgrade multer to 2.0.1 or later.","what":"CVE-2025-48997 is a high-severity denial of service vulnerability in expressjs multer, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-48997 and fix it if it is affected.\n\nWhat it is: CVE-2025-48997 is a high-severity denial of service vulnerability in expressjs multer, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-48997 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.1\n- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-48997/ (Markdown: https://insights.sbomify.com/CVE-2025-48997/index.md)","id":"CVE-2025-48997","markdown":"https://insights.sbomify.com/CVE-2025-48997/index.md","name":"CVE-2025-48997","record":{"aliases":["ECHO-05c8-97e7-5c87","GHSA-g5hg-p3ph-g8qg","MINI-qmch-926m-x8qr","ROOT-APP-NPM-CVE-2025-48997"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js multipart middleware","requires_auth":"none","summary":"An attacker can crash the application by sending a multipart upload with an empty field name, causing an unhandled exception.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to `2.0.1` to receive a patch. No known workarounds are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multer vulnerable to Denial of Service via unhandled exception","id":"CVE-2025-48997","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Dataease MYSQL JDBC File Reading Vulnerability","id":"CVE-2025-48998"},"packages":[{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["1.4.4-lts.1"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-g5hg-p3ph-g8qg"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["1.4.4-lts.1"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-g5hg-p3ph-g8qg"}],"prev":{"headline":"Unauthenticated Disclosure of PSU HAX CMS Site Listings via haxPsuUsage API Endpoint","id":"CVE-2025-48996"},"products":["multer"],"published":"2025-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["expressjs"]},"summary":"An attacker can crash the application by sending a multipart upload with an empty field name, causing an unhandled exception.","url":"https://insights.sbomify.com/CVE-2025-48997/"}