# CVE-2025-48997: Multer vulnerable to Denial of Service via unhandled exception

> An attacker can crash the application by sending a multipart upload with an empty field name, causing an unhandled exception.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2025
- **Updated:** 3 Jun 2025
- **Also known as:** ECHO-05c8-97e7-5c87, GHSA-g5hg-p3ph-g8qg, MINI-qmch-926m-x8qr, ROOT-APP-NPM-CVE-2025-48997

## What is CVE-2025-48997?

CVE-2025-48997 is a high-severity denial of service vulnerability in expressjs multer, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to `2.0.1` to receive a patch. No known workarounds are available.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-48997?

2 open source packages ship an affected version, including multer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | From 1.4.4-lts.1 | 2.0.1 |
| `multer` | npm | From 1.4.4-lts.1 | 2.0.1 |

## How do I fix CVE-2025-48997?

Upgrade multer to 2.0.1 or later.

## Is CVE-2025-48997 being exploited?

There is no known exploitation of CVE-2025-48997 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-48997 and fix it if it is affected.

What it is: CVE-2025-48997 is a high-severity denial of service vulnerability in expressjs multer, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-48997 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.1
- multer (npm): affected from 1.4.4-lts.1; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-48997/ (Markdown: https://insights.sbomify.com/CVE-2025-48997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-48997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-48997
- OSV: https://osv.dev/vulnerability/CVE-2025-48997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-48997/
Summaries are generated and may contain mistakes; the official description above is the record.
