{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49002 exists.","fix":"No fix has been published for CVE-2025-49002 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-49002 is a high-severity code injection vulnerability in Dataease Dataease, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49002 and fix it if it is affected.\n\nWhat it is: CVE-2025-49002 is a high-severity code injection vulnerability in Dataease Dataease, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49002 exists.\n\nAffected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49002/ (Markdown: https://insights.sbomify.com/CVE-2025-49002/index.md)","id":"CVE-2025-49002","markdown":"https://insights.sbomify.com/CVE-2025-49002/index.md","name":"CVE-2025-49002","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"DataEase BI tool","requires_auth":"none","summary":"Attackers can bypass security patches to execute arbitrary code in DataEase by exploiting case-insensitive command filtering flaws.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"DataEase is an open source business intelligence and data visualization tool. Versions prior to version 2.10.10 have a flaw in the patch for CVE-2025-32966 that allow the patch to be bypassed through case insensitivity because INIT and RUNSCRIPT are prohibited. The vulnerability has been fixed in v2.10.10. No known workarounds are available.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-10-21","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-10-21T10:11:21Z","kind":"github_poc","ref":"https://github.com/Feng-Huang-0520/DataEase_Postgresql_JDBC_Bypass-CVE-2025-49002","stars":1,"title":"飞致云 DataEase Postgresql JDBC Bypass 远程代码执行漏洞 CVE-2025-49002 漏洞类型 RCE"},{"date":"2025-10-22T01:13:22Z","kind":"github_poc","ref":"https://github.com/jiuzui129-arch/CVE-2025-49002","stars":0,"title":null},{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-49002.yaml","stars":null,"title":"DataEase - Remote Code Execution"}],"tier":"weaponised"},"has_fix":false,"headline":"Dataease H2 Database Remote Code Execution (RCE) Bypass Vulnerability","id":"CVE-2025-49002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"dataease:dataease","products":["dataease:dataease"],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Dataease H2 JDBC Connection Remote Code Execution","id":"CVE-2025-49003"},"packages":[],"prev":{"headline":"Dataease Authentication Bypass Vulnerability","id":"CVE-2025-49001"},"products":["dataease"],"published":"2025-06-03","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":9.8,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","kev_date_added":null,"published":"2022-07-22"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["dataease"]},"summary":"Attackers can bypass security patches to execute arbitrary code in DataEase by exploiting case-insensitive command filtering flaws.","url":"https://insights.sbomify.com/CVE-2025-49002/"}