# CVE-2025-49004: Hijacking Caido instance during the initial setup via DNS Rebinding to achieve RCE

> Attackers can hijack Caido instances via DNS rebinding to achieve remote code execution during initial setup or authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-jmxf-xw2r-vjrg

## What is CVE-2025-49004?

CVE-2025-49004 is a high-severity server-side request forgery vulnerability in caido, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Caido is a web security auditing toolkit. Prior to version 0.48.0, due to the lack of protection for DNS rebinding, Caido can be loaded on an attacker-controlled domain. This allows a malicious website to hijack the authentication flow of Caido and achieve code execution. A malicious website loaded in the browser can hijack the locally running Caido instance and achieve remote command execution during the initial setup. Even if the Caido instance is already configured, an attacker can initiate the authentication flow by performing DNS rebinding. In this case, the victim needs to authorize the request on dashboard.caido.io. Users should upgrade to version 0.48.0 to receive a patch.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-49004?


## How do I fix CVE-2025-49004?

No fix has been published for CVE-2025-49004 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49004 being exploited?

There is no known exploitation of CVE-2025-49004 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49004 and fix it if it is affected.

What it is: CVE-2025-49004 is a high-severity server-side request forgery vulnerability in caido, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-49004 in the wild and no public exploit code.

Affected product: caido. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49004/ (Markdown: https://insights.sbomify.com/CVE-2025-49004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49004
- OSV: https://osv.dev/vulnerability/CVE-2025-49004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49004/
Summaries are generated and may contain mistakes; the official description above is the record.
