# CVE-2025-49005: Next.js cache poisoning due to omission of Vary header

> Attackers can poison caches by serving RSC payloads as HTML, potentially exposing sensitive data or bypassing security controls in self-hosted Next.js deployments.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2025
- **Updated:** 8 Jul 2025
- **Also known as:** CLEANSTART-2026-SA24453, GHSA-r2fc-ccr8-96c4

## What is CVE-2025-49005?

CVE-2025-49005 is a low-severity vulnerability in Vercel Next.js, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. In Next.js App Router from 15.3.0 to before 15.3.3 and Vercel CLI from 41.4.1 to 42.2.0, a cache poisoning vulnerability was found. The issue allowed page requests for HTML content to return a React Server Component (RSC) payload instead under certain conditions. When deployed to Vercel, this would only impact the browser cache, and would not lead to the CDN being poisoned. When self-hosted and deployed externally, this could lead to cache poisoning if the CDN does not properly distinguish between RSC / HTML in the cache keys. This issue has been resolved in Next.js 15.3.3.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-49005?

2 open source packages ship an affected version, including next. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 15.3.0 | 15.3.3 |
| `next` | npm | From 15.3.0 | 15.3.3 |

Products: Vercel Next.js, Vercel Vercel.

## How do I fix CVE-2025-49005?

Upgrade next to 15.3.3 or later.

## Is CVE-2025-49005 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49005 exists.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49005 and fix it if it is affected.

What it is: CVE-2025-49005 is a low-severity vulnerability in Vercel Next.js, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49005 exists.

Affected packages and fixed versions:
- next (npm): affected from 15.3.0; fixed in 15.3.3
- next (npm): affected from 15.3.0; fixed in 15.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49005/ (Markdown: https://insights.sbomify.com/CVE-2025-49005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49005
- OSV: https://osv.dev/vulnerability/CVE-2025-49005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49005/
Summaries are generated and may contain mistakes; the official description above is the record.
