{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-49006 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-49006 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-49006 is a high-severity authentication bypass vulnerability in wasp-lang wasp, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49006 and fix it if it is affected.\n\nWhat it is: CVE-2025-49006 is a high-severity authentication bypass vulnerability in wasp-lang wasp, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-49006 in the wild and no public exploit code.\n\nAffected product: wasp-lang wasp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49006/ (Markdown: https://insights.sbomify.com/CVE-2025-49006/index.md)","id":"CVE-2025-49006","markdown":"https://insights.sbomify.com/CVE-2025-49006/index.md","name":"CVE-2025-49006","record":{"aliases":["GHSA-qvjc-6xv7-6v5f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Wasp web framework","requires_auth":"none","summary":"Wasp framework allows user impersonation and privilege escalation via case-insensitive OAuth ID handling when using Keycloak with case-sensitive IDs.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"Wasp (Web Application Specification) is a Rails-like framework for React, Node.js, and Prisma. Prior to version 0.16.6, Wasp authentication has a vulnerability in the OAuth authentication implementation (affecting only Keycloak with a specific config). Wasp currently lowercases OAuth user IDs before storing / fetching them. This behavior violates OAuth and OpenID Connect specifications and can result in user impersonation, account collisions, and privilege escalation. In practice, out of the OAuth providers that Wasp auth supports, only Keycloak is affected. Keycloak uses a lowercase UUID by default, but users can configure it to be case sensitive, making it affected. Google, GitHub, and Discord use numerical IDs, making them not affected. Users should update their Wasp version to `0.16.6` which has a fix for the problematic behavior. Users using Keycloak can work around the issue by not using a case sensitive user ID in their realm configuration.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Wasp has case insensitive OAuth ID vulnerability","id":"CVE-2025-49006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"ReDoS Vulnerability in Rack::Multipart handle_mime_head","id":"CVE-2025-49007"},"packages":[],"prev":{"headline":"Next.js cache poisoning due to omission of Vary header","id":"CVE-2025-49005"},"products":["wasp"],"published":"2025-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-09","vendors":["wasp-lang"]},"summary":"Wasp framework allows user impersonation and privilege escalation via case-insensitive OAuth ID handling when using Keycloak with case-sensitive IDs.","url":"https://insights.sbomify.com/CVE-2025-49006/"}