# CVE-2025-49006: Wasp has case insensitive OAuth ID vulnerability

> Wasp framework allows user impersonation and privilege escalation via case-insensitive OAuth ID handling when using Keycloak with case-sensitive IDs.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-qvjc-6xv7-6v5f

## What is CVE-2025-49006?

CVE-2025-49006 is a high-severity authentication bypass vulnerability in wasp-lang wasp, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wasp (Web Application Specification) is a Rails-like framework for React, Node.js, and Prisma. Prior to version 0.16.6, Wasp authentication has a vulnerability in the OAuth authentication implementation (affecting only Keycloak with a specific config). Wasp currently lowercases OAuth user IDs before storing / fetching them. This behavior violates OAuth and OpenID Connect specifications and can result in user impersonation, account collisions, and privilege escalation. In practice, out of the OAuth providers that Wasp auth supports, only Keycloak is affected. Keycloak uses a lowercase UUID by default, but users can configure it to be case sensitive, making it affected. Google, GitHub, and Discord use numerical IDs, making them not affected. Users should update their Wasp version to `0.16.6` which has a fix for the problematic behavior. Users using Keycloak can work around the issue by not using a case sensitive user ID in their realm configuration.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-49006?


## How do I fix CVE-2025-49006?

No fix has been published for CVE-2025-49006 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49006 being exploited?

There is no known exploitation of CVE-2025-49006 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49006 and fix it if it is affected.

What it is: CVE-2025-49006 is a high-severity authentication bypass vulnerability in wasp-lang wasp, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49006 in the wild and no public exploit code.

Affected product: wasp-lang wasp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49006/ (Markdown: https://insights.sbomify.com/CVE-2025-49006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49006
- OSV: https://osv.dev/vulnerability/CVE-2025-49006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49006/
Summaries are generated and may contain mistakes; the official description above is the record.
