# CVE-2025-49011: SpiceDB checks involving relations with caveats can result in no permission when permission is expected

> SpiceDB may incorrectly deny permissions when resolving complex caveated relations, requiring an upgrade to fix.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2025
- **Updated:** 6 Jun 2025
- **Also known as:** GHSA-cwwm-hr97-qfxm, GO-2025-3744

## What is CVE-2025-49011?

CVE-2025-49011 is a low-severity vulnerability in authzed spicedb, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SpiceDB is an open source database for storing and querying fine-grained authorization data. Prior to version 1.44.2, on schemas involving arrows with caveats on the arrow’ed relation, when the path to resolve a CheckPermission request involves the evaluation of multiple caveated branches, requests may return a negative response when a positive response is expected. Version 1.44.2 fixes the issue. As a workaround, do not use caveats in the schema over an arrow’ed relation.

Weakness: CWE-358 (Improperly Implemented Security Check for Standard)

## Which versions are affected by CVE-2025-49011?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | All versions | 1.44.2 |
| `github.com/authzed/spicedb` | Go | All versions | 1.44.2 |
| `github.com/authzed/spicedb` | Go | All versions | 1.44.2 |

Products: Authzed Spicedb.

## How do I fix CVE-2025-49011?

Upgrade github.com/authzed/spicedb to 1.44.2 or later.

## Is CVE-2025-49011 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49011 exists.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49011 and fix it if it is affected.

What it is: CVE-2025-49011 is a low-severity vulnerability in authzed spicedb, published on 6 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49011 exists.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.44.2
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.44.2
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.44.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49011/ (Markdown: https://insights.sbomify.com/CVE-2025-49011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49011
- OSV: https://osv.dev/vulnerability/CVE-2025-49011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49011/
Summaries are generated and may contain mistakes; the official description above is the record.
