# CVE-2025-49015: Couchbase .NET SDK (client library) does not properly enable hostname verification for TLS certificates

> The Couchbase .NET SDK fails to verify TLS hostnames by default, allowing attackers to bypass certificate validation and potentially intercept traffic.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2025
- **Updated:** 18 Jun 2025
- **Also known as:** GHSA-px2c-r924-mwcc

## What is CVE-2025-49015?

CVE-2025-49015 is a medium-severity vulnerability in n/a, published on 18 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Couchbase .NET SDK (client library) before 3.7.1 does not properly enable hostname verification for TLS certificates. In fact, the SDK was also using IP addresses instead of hostnames due to a configuration option that was incorrectly enabled by default.

Weakness: CWE-297 (Improper Validation of Certificate with Host Mismatch)

## Which versions are affected by CVE-2025-49015?

2 open source packages ship an affected version, including CouchbaseNetClient. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `CouchbaseNetClient` | NuGet | All versions | 3.7.1 |
| `CouchbaseNetClient` | NuGet | All versions | 3.7.1 |

Products: Couchbase .Net Sdk.

## How do I fix CVE-2025-49015?

Upgrade CouchbaseNetClient to 3.7.1 or later.

## Is CVE-2025-49015 being exploited?

There is no known exploitation of CVE-2025-49015 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49015 and fix it if it is affected.

What it is: CVE-2025-49015 is a medium-severity vulnerability in n/a, published on 18 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49015 in the wild and no public exploit code.

Affected packages and fixed versions:
- CouchbaseNetClient (NuGet): affected all versions; fixed in 3.7.1
- CouchbaseNetClient (NuGet): affected all versions; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49015/ (Markdown: https://insights.sbomify.com/CVE-2025-49015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49015
- OSV: https://osv.dev/vulnerability/CVE-2025-49015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49015/
Summaries are generated and may contain mistakes; the official description above is the record.
