{"answers":{"affected":"3 open source packages ship an affected version, including valkey, keydb and redis.","exploited":"There is no known exploitation of CVE-2025-49112 in the wild and no public exploit code.","fix":"Upgrade valkey to 8.1.4 or later.","what":"CVE-2025-49112 is a low-severity vulnerability in Valkey, published on 2 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49112 and fix it if it is affected.\n\nWhat it is: CVE-2025-49112 is a low-severity vulnerability in Valkey, published on 2 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-49112 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- valkey (Bitnami): affected all versions; fixed in 8.1.4\n- keydb (Bitnami): affected all versions; no fix listed\n- redis (Bitnami): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49112/ (Markdown: https://insights.sbomify.com/CVE-2025-49112/index.md)","id":"CVE-2025-49112","markdown":"https://insights.sbomify.com/CVE-2025-49112/index.md","name":"CVE-2025-49112","record":{"aliases":["AZL-62243","BELL-CVE-2025-49112","BIT-keydb-2025-49112","BIT-redis-2025-49112","BIT-valkey-2025-49112","DEBIAN-CVE-2025-49112","ECHO-b783-e6af-4b18","GHSA-xhp4-6g9v-4xvj","MINI-7572-3r96-5qwh","MINI-886r-24pv-pvc5","MINI-fr5v-vcfw-cxq2","MINI-hf4m-8m99-999f","MINI-qjr4-mqfp-w48x","MINI-r5q4-r7gc-9gx5","MINI-v3pg-2xjr-62vh","MINI-vmvm-gfwm-g8j3","MINI-xmpj-hc89-mrr5","UBUNTU-CVE-2025-49112"],"analysis":{"component_type":"database","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Valkey database","requires_auth":"none","summary":"An integer underflow in Valkey's networking code can lead to a denial of service condition, requiring administrators to apply security patches.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"}],"description":"setDeferredReply in networking.c in Valkey through 8.1.1 has an integer underflow for prev-\u003esize - prev-\u003eused.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in Valkey","id":"CVE-2025-49112","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":[],"last_affected":[],"package":"keydb","purl":"pkg:bitnami/keydb","source":"BIT-keydb-2025-49112"},{"ecosystem":"Bitnami","fixed":[],"introduced":[],"last_affected":[],"package":"redis","purl":"pkg:bitnami/redis","source":"BIT-redis-2025-49112"},{"ecosystem":"Bitnami","fixed":["8.1.4"],"introduced":["0"],"last_affected":[],"package":"valkey","purl":"pkg:bitnami/valkey","source":"BIT-valkey-2025-49112"}],"prev":{"headline":"Command injection in Konsole","id":"CVE-2025-49091"},"products":["Valkey"],"published":"2025-06-02","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-02","vendors":["Valkey"]},"summary":"An integer underflow in Valkey's networking code can lead to a denial of service condition, requiring administrators to apply security patches.","url":"https://insights.sbomify.com/CVE-2025-49112/"}