CVE-2025-49113 RoundCube Webmail Deserialization of Untrusted Data

Exploited in the wild Critical 9.9 Published Updated

Authenticated attackers can achieve remote code execution in Roundcube Webmail via unsafe PHP object deserialization in the upload settings.

Exploited in the wild
Since 20 Feb 2026
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-49113?

CVE-2025-49113 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the _from parameter in a URL is not validated in program/actions/settings/upload.php, leading to PHP Object Deserialization.

Weakness: CWE-502

Which versions are affected by CVE-2025-49113?

4 open source packages ship an affected version, including roundcube/roundcubemail. It affects 2 products.

PackageAffectedFixed in
roundcube/roundcubemail PackagistAll versions1.5.10
roundcube/roundcubemail PackagistAll versions1.5.10
roundcube/roundcubemail PackagistFrom 1.6.01.6.11
roundcube/roundcubemail PackagistFrom 1.6.01.6.11

Products include Debian Debian Linux, Roundcube Webmail.

How do I fix CVE-2025-49113?

Upgrade roundcube/roundcubemail to a fixed version for your release line: 1.5.10 or 1.6.11. US federal agencies must fix it by 13 Mar 2026.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-49113 being exploited?

Yes. Attackers have exploited CVE-2025-49113 in the wild since at least 20 Feb 2026.

Public exploit code: 1 Metasploit module, 1 Exploit-DB entry, 1 Nuclei template and 23 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as CVE-2025-48745, DEBIAN-CVE-2025-49113, DLA-4211-1, DSA-5934-1, GHSA-8j8w-wwqc-x596, MGASA-2025-0185 and 2 more.

Is CVE-2025-49113 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free