# CVE-2025-49113: RoundCube Webmail Deserialization of Untrusted Data

> Authenticated attackers can achieve remote code execution in Roundcube Webmail via unsafe PHP object deserialization in the upload settings.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 20 Feb 2026 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2025
- **Updated:** 21 Feb 2026
- **Also known as:** CVE-2025-48745, DEBIAN-CVE-2025-49113, DLA-4211-1, DSA-5934-1, GHSA-8j8w-wwqc-x596, MGASA-2025-0185, UBUNTU-CVE-2025-49113, USN-7584-1

## What is CVE-2025-49113?

CVE-2025-49113 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the _from parameter in a URL is not validated in program/actions/settings/upload.php, leading to PHP Object Deserialization.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-49113?

4 open source packages ship an affected version, including roundcube/roundcubemail. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundcube/roundcubemail` | Packagist | All versions | 1.5.10 |
| `roundcube/roundcubemail` | Packagist | All versions | 1.5.10 |
| `roundcube/roundcubemail` | Packagist | From 1.6.0 | 1.6.11 |
| `roundcube/roundcubemail` | Packagist | From 1.6.0 | 1.6.11 |

Products: Debian Debian Linux, Roundcube Webmail.

## How do I fix CVE-2025-49113?

Upgrade roundcube/roundcubemail to a fixed version for your release line: 1.5.10 or 1.6.11. US federal agencies must fix it by 13 Mar 2026.

## Is CVE-2025-49113 being exploited?

Yes. Attackers have exploited CVE-2025-49113 in the wild since at least 20 Feb 2026.

Public exploit code:

- https://github.com/fearsoff-org/CVE-2025-49113 (github_poc): https://github.com/fearsoff-org/CVE-2025-49113
- Proof of Concept demonstrating Remote Code Execution through insecure deserialization in Roundcube (CVE-2025-49113). (github_poc): https://github.com/hakaioffsec/CVE-2025-49113-exploit
- 💥 Python Exploit for CVE-2025-49113 | Roundcube Webmail RCE via PHP Object Injection (github_poc): https://github.com/00xCanelo/CVE-2025-49113
- Proof-of-concept to CVE-2025-49113 (github_poc): https://github.com/BiiTts/Roundcube-CVE-2025-49113
- Detection for CVE-2025-49113 (github_poc): https://github.com/rxerium/CVE-2025-49113
- POC of CVE-2025-49113 (github_poc): https://github.com/Zwique/CVE-2025-49113

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)
- [CVE-2022-30333](https://insights.sbomify.com/CVE-2022-30333/): RARLAB UnRAR Directory Traversal (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49113 and fix it if it is affected.

What it is: CVE-2025-49113 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-49113 in the wild since at least 20 Feb 2026.

Affected packages and fixed versions:
- roundcube/roundcubemail (Packagist): affected all versions; fixed in 1.5.10
- roundcube/roundcubemail (Packagist): affected all versions; fixed in 1.5.10
- roundcube/roundcubemail (Packagist): affected from 1.6.0; fixed in 1.6.11
- roundcube/roundcubemail (Packagist): affected from 1.6.0; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49113/ (Markdown: https://insights.sbomify.com/CVE-2025-49113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49113
- OSV: https://osv.dev/vulnerability/CVE-2025-49113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49113/
Summaries are generated and may contain mistakes; the official description above is the record.
