CVE-2025-49124 Apache Tomcat: exe side-loading via icalcs.exe in Tomcat installer for Windows
Attackers can execute arbitrary code during Windows installation via untrusted search path in the Tomcat installer.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-49124?
CVE-2025-49124 is a high-severity vulnerability in Apache Tomcat, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Weakness: CWE-426
Which versions are affected by CVE-2025-49124?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.23 | 9.0.106 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.23 | 9.0.106 |
13 more packages
tomcat Bitnami | From 9.0.23 | 9.0.107, 10.1.42, 11.0.9 |
org.apache.tomcat:tomcat Maven | From 10.1.0 | 10.1.42 |
org.apache.tomcat:tomcat Maven | From 10.1.0 | 10.1.42 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat Maven | From 9.0.23 | 9.0.106 |
org.apache.tomcat:tomcat Maven | From 9.0.23 | 9.0.106 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.23 | 9.0.106 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.23 | 9.0.106 |
Products include Apache Tomcat.
How do I fix CVE-2025-49124?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.
Is CVE-2025-49124 being exploited?
There is no known exploitation of CVE-2025-49124 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-49124, GHSA-42wg-hm62-jcwg, ROOT-APP-MAVEN-CVE-2025-49124.