# CVE-2025-49124: Apache Tomcat: exe side-loading via icalcs.exe in Tomcat installer for Windows

> Attackers can execute arbitrary code during Windows installation via untrusted search path in the Tomcat installer.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2025
- **Updated:** 29 Oct 2025
- **Also known as:** BIT-tomcat-2025-49124, GHSA-42wg-hm62-jcwg, ROOT-APP-MAVEN-CVE-2025-49124

## What is CVE-2025-49124?

CVE-2025-49124 is a high-severity vulnerability in Apache Tomcat, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected.

Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2025-49124?

19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0 | 10.1.42 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0 | 10.1.42 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.23 | 9.0.106 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.23 | 9.0.106 |
| `tomcat` | Bitnami | From 9.0.23 | 9.0.107, 10.1.42, 11.0.9 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0 | 10.1.42 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0 | 10.1.42 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.23 | 9.0.106 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.23 | 9.0.106 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0 | 10.1.42 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0 | 10.1.42 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.23 | 9.0.106 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.23 | 9.0.106 |

Products: Apache Tomcat.

## How do I fix CVE-2025-49124?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.

## Is CVE-2025-49124 being exploited?

There is no known exploitation of CVE-2025-49124 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49124 and fix it if it is affected.

What it is: CVE-2025-49124 is a high-severity vulnerability in Apache Tomcat, published on 16 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49124 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0; fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0; fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.23; fixed in 9.0.106
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.23; fixed in 9.0.106
- tomcat (Bitnami): affected from 9.0.23; fixed in 9.0.107, 10.1.42, 11.0.9
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0; fixed in 10.1.42
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0; fixed in 10.1.42
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat:tomcat (Maven): affected from 9.0.23; fixed in 9.0.106

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49124/ (Markdown: https://insights.sbomify.com/CVE-2025-49124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49124
- OSV: https://osv.dev/vulnerability/CVE-2025-49124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49124/
Summaries are generated and may contain mistakes; the official description above is the record.
