CVE-2025-49125 Apache Tomcat: Security constraint bypass for pre/post-resources
Attackers can bypass security constraints on PreResources or PostResources by accessing them via unexpected paths when not mounted at the root.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-49125?
CVE-2025-49125 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Weakness: CWE-288
Which versions are affected by CVE-2025-49125?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.106 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.106 |
tomcat Bitnami | All versions | 9.0.106, 10.1.42, 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.42 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.8 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.106 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0.M1 | 9.0.106 |
Products include Apache Tomcat.
How do I fix CVE-2025-49125?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-49125 being exploited?
There is no known exploitation of CVE-2025-49125 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-49125, CLSA-2025-1753056170, CLSA-2026-1781744120, DEBIAN-CVE-2025-49125, GHSA-wc4r-xq3c-5cf3, ROOT-APP-MAVEN-CVE-2025-49125 and 1 more.