# CVE-2025-49125: Apache Tomcat: Security constraint bypass for pre/post-resources

> Attackers can bypass security constraints on PreResources or PostResources by accessing them via unexpected paths when not mounted at the root.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-tomcat-2025-49125, CLSA-2025-1753056170, CLSA-2026-1781744120, DEBIAN-CVE-2025-49125, GHSA-wc4r-xq3c-5cf3, ROOT-APP-MAVEN-CVE-2025-49125, UBUNTU-CVE-2025-49125

## What is CVE-2025-49125?

CVE-2025-49125 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat.  When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions 
may also be affected.

Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2025-49125?

17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.106 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0.M1 | 9.0.106 |
| `tomcat` | Bitnami | All versions | 9.0.106, 10.1.42, 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.0-M1 | 10.1.42 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M1 | 11.0.8 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0.M1 | 9.0.106 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.0.M1 | 9.0.106 |

Products: Apache Tomcat.

## How do I fix CVE-2025-49125?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.42, 11.0.8 or 9.0.106.

## Is CVE-2025-49125 being exploited?

There is no known exploitation of CVE-2025-49125 in the wild and no public exploit code.

Public exploit code:

- Tomcat CVE (github_poc): https://github.com/gregk4sec/CVE-2025-49125

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49125 and fix it if it is affected.

What it is: CVE-2025-49125 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49125 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.106
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0.M1; fixed in 9.0.106
- tomcat (Bitnami): affected all versions; fixed in 9.0.106, 10.1.42, 11.0.8
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.0-M1; fixed in 10.1.42
- org.apache.tomcat:tomcat-catalina (Maven): affected from 11.0.0-M1; fixed in 11.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49125/ (Markdown: https://insights.sbomify.com/CVE-2025-49125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49125
- OSV: https://osv.dev/vulnerability/CVE-2025-49125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49125/
Summaries are generated and may contain mistakes; the official description above is the record.
