{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49126 exists.","fix":"No fix has been published for CVE-2025-49126 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-49126 is a high-severity cross-site scripting vulnerability in Visionatrix, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-49126 and fix it if it is affected.\n\nWhat it is: CVE-2025-49126 is a high-severity cross-site scripting vulnerability in Visionatrix, published on 23 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49126 exists.\n\nAffected product: Visionatrix. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49126/ (Markdown: https://insights.sbomify.com/CVE-2025-49126/index.md)","id":"CVE-2025-49126","markdown":"https://insights.sbomify.com/CVE-2025-49126/index.md","name":"CVE-2025-49126","record":{"aliases":["GHSA-w36r-9jvx-q48v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"AI media processing tool","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via reflected XSS to hijack user sessions and steal secrets from the Visionatrix application.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Visionatrix is an AI Media processing tool using ComfyUI. In versions 1.5.0 to before 2.5.1, the /docs/flows endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack allowing full takeover of the application and exfiltration of secrets stored in the application. The implementation uses the get_swagger_ui_html function from FastAPI. This function does not encode or sanitize its arguments before using them to generate the HTML for the swagger documentation page and is not intended to be used with user-controlled arguments. Any user of this application can be targeted with a one-click attack that can takeover their session and all the secrets that may be contained within it. This issue has been patched in version 2.5.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Visionatrix Vulnerable to Reflected XSS Leading to Exfiltration of Secrets","id":"CVE-2025-49126","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Kafbat UI vulnerable to Remote Code Execution by JMX in Metrices Configuration","id":"CVE-2025-49127"},"packages":[],"prev":{"headline":"Apache Tomcat: Security constraint bypass for pre/post-resources","id":"CVE-2025-49125"},"products":["Visionatrix"],"published":"2025-06-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["Visionatrix"]},"summary":"Attackers can execute arbitrary scripts via reflected XSS to hijack user sessions and steal secrets from the Visionatrix application.","url":"https://insights.sbomify.com/CVE-2025-49126/"}